无法更新Firebase依赖项(com.google.firebase)

我已经添加到Android应用程序的Firebase推送通知。 在使用之前,我已经更新了build.gradle。 它的工作正常。

compile 'com.google.firebase:firebase-messaging:9.2.0' 

现在我已经更新到最新的库,但得到错误。

  dependencies { //.... compile 'com.google.firebase:firebase-core:10.0.1' } 

我在重build项目时遇到了错误

错误:configuration项目“:app”时发生问题。 无法parsingconfiguration的所有依赖关系:“app:_debugApkCopy”。 找不到com.google.firebase:firebase-core:10.0.1。 要求:DGApp:应用程序:未指定

先谢谢你。

Solutions Collecting From Web of "无法更新Firebase依赖项(com.google.firebase)"

您必须从独立SDKpipe理器更新您的Google Play服务和Google储存库。

首先,打开Android Studio并点击顶部工具栏上的这个图标:

图片

然后,当对话框启动时,点击对话框左下angular的“启动独立SDKpipe理器”:

图片

要确保更新/安装的东西以外,请单击“全部取消”:

图片

当“独立SDKpipe理器”窗口打开时,查找“Extras”并将其折叠。 你应该看到“Google Play Services”和“Google Repository”,在右边你会看到“Update Available:{something}” 。 select这些项目,然后单击“安装”。

图片

当他们完成安装,错误将消失。

添加google-services插件

在build.gradle文件中,包含google-services插件:

 buildscript { // ... dependencies { // ... classpath 'com.google.gms:google-services:3.0.0' } } 

然后,在您的模块Gradle文件(通常是app / build.gradle)中,在文件底部添加apply插件行以启用Gradle插件:

 apply plugin: 'com.android.application' android { // ... } dependencies { // ... compile 'com.google.firebase:firebase-core:10.0.1' // Getting a "Could not find" error? Make sure you have // the latest Google Repository in the Android SDK manager } // ADD THIS AT THE BOTTOM apply plugin: 'com.google.gms.google-services' 

有关详情,请参阅Firebase设置

如果您阅读文档,则表示您Google Repository in the Android SDK manager更新最新的Google Repository in the Android SDK manager

所以,只要去Android SDK Managerinstall the latest version of below two libraries

1-Google Play服务

2-Google存储库

检查文档中的图像:

在这里输入图像说明

获取“无法find”错误? 确保您在Android SDKpipe理器中拥有最新的Google Repository。

为了解决问题;

  • 在Android 7.0(API 24)下打开SDK Manager并更新最新的特别是Google API的SDK工具

我只使用Android Studio SDK Manager工作。

与其他用户一样,build议使用独立工具,但没有运气

可能是你没有给出正确的回购。

 repositories { maven { url 'https://maven.fabric.io/public' } }