FloatingActionButton类不能被实例化

在看了Material Design中的新方法之后,我尝试在应用程序中实现一个浮动操作button。 但是,我在预览(预览Android版本21)中出现此错误:

The following classes could not be instantiated: - android.support.design.widget.FloatingActionButton (First paragraph of error) java.lang.NullPointerException at android.support.v4.graphics.drawable.DrawableCompatLollipop.setTintList(DrawableCompatLollipop.java:56) at android.support.v4.graphics.drawable.DrawableCompat$LollipopDrawableImpl.setTintList(DrawableCompat.java:145) at android.support.v4.graphics.drawable.DrawableCompat.setTintList(DrawableCompat.java:270) etc... 

任何人有任何想法? 这是我的build.gradle:

 android { compileSdkVersion 22 buildToolsVersion "22.0.1" classpath 'com.android.tools.build:gradle:1.2.3' defaultConfig { applicationId "owensetiawan.tutorials.fab" minSdkVersion 15 targetSdkVersion 22 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.2.0' compile 'com.android.support:design:22.2.0' } 

如果有人能帮我解释一下我的问题,那将是非常棒的。

Solutions Collecting From Web of "FloatingActionButton类不能被实例化"

嘿,我得到了与devise库的实例化相同的问题,并通过这个解决了它

第1步>代码为fab

  <android.support.design.widget.FloatingActionButton android:layout_width="wrap_content" android:layout_height="wrap_content" android:layout_gravity="bottom" android:clickable="true" android:src="@drawable/search" app:backgroundTint="@color/color_fav" app:borderWidth="0dp" android:layout_alignParentBottom="true" android:layout_alignParentEnd="true" /> 

步骤2>依赖

  compile 'com.android.support:appcompat-v7:22.2.1' compile 'com.android.support:recyclerview-v7:22.2.1' compile 'com.android.support:design:22.2.1' compile "com.android.support:support-v4:22.2.1" 

步骤3>以上问题的主要步骤

简单的一个: – 去你的XML,点击预览,并在预览栏中selectAP1 21

确保AppCompat库版本devise支持库相同的 。 这主要是一个内部依赖冲突,保持两个版本相同的固定我: –

 compile 'com.android.support:appcompat-v7:24.2.1' compile 'com.android.support:design:24.2.1' 

我有同样的问题更新“Android支持库”(22.2.1)。 阅读我的答案相同types的问题。 无法设置浮动操作button,因为无法find类(Android Studio)

我有一个类似的错误,只需将Manifest从:

 <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="victor.com.ec.gastos_diarios"> <application android:allowBackup="true" android:icon="@mipmap/ic_launcher" android:label="@string/app_name" android:supportsRtl="true" android:theme="@style/AppTheme"> <activity android:name=".ActividadPrincipal"> <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> </application> </manifest> 

 <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="victor.com.ec.gastos_diarios"> <application android:allowBackup="true" android:icon="@mipmap/ic_launcher" android:label="@string/app_name" android:supportsRtl="true" android:theme="@style/AppTheme"> <activity android:name=".ActividadPrincipal" android:theme="@style/AppTheme.NoActionBar">> <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> </application> </manifest>