使用FragmentStatePagerAdapter而不支持库

我想知道是否有可能使用类FragmentStatePagerAdapter或其同等没有支持库?

我知道如何使用本地碎片来代替支持库中的碎片,而其他许多类都有相似的等价物,但是我找不到应该使用什么类来代替这个类。

我基本上想扩展它在我这样的适配器中使用它

public class ImageAdapter extends FragmentStatePagerAdapter {... 

Solutions Collecting From Web of "使用FragmentStatePagerAdapter而不支持库"

我认为你已经阅读了ViewPager 文档 ,但以防万一:

这个class目前正在进行早期的devise和开发。 该API可能会在稍后的兼容性库更新中发生变化,在针对新版本编译时需要更改应用程序的源代码。

最初,我也很困惑,为什么PagerAdapter类不是android.app.*命名空间的一部分。 由于它们还在不断完善之中,它们已经被包含在支持库中,所以这些库可以在引入更改时经常更新(AOSP更新远不方便,因此出现的频率要低得多)。 看来,一旦Android团队对ViewPager及其所有相关类进行最终形成,他们将成为AOSP的一部分。 即使ViewPager类本身仍然是V4支持库的一部分。 所以你想在不久的将来有可能… 🙂