Genymotion设备不能在OS X Yosemite的Eclipse上工作

我从小牛队更新到优胜美地,现在我不能再使用任何Genymotion装置。
您可以在Eclipse中看到这些设备,但是当您想运行一个应用程序时,您不能select其中一个设备。

我已经重新安装了Eclipse,Genymotion和Virtualbox …

Genymotion虚拟设备pipe理器显示一个Nexus 5,声明为“开” Genymotion虚拟设备管理器显示Nexus 5,并且该属性为“开”

当我想运行我的应用程序,没有Nexus 5 .. Android设备选择器不显示Nexus 5

Solutions Collecting From Web of "Genymotion设备不能在OS X Yosemite的Eclipse上工作"

这是eclipse中的一个bug – OSX优胜美地,你需要做的是在Android设备select器窗口中,尝试调整序列号选项卡,你会看到正在运行的genymotion模拟器

如果您没有看到,或者Android设备选配器窗口不出现,请在再次运行之前检查三件事情:

  1. 开发人员选项是从设置启用(通过重复触摸7倍的电话版本号),即使开发人员选项可用在genymotion模拟器中的应用程序列表
  2. 在“设置”>“安全”中,确保启用“未知来源”
  3. 转到运行configuration(对于Android应用程序),select目标选项卡,启用总是提示select设备,然后点击应用。

另外我手动从Genymotion下载页面下载了jar文件,并将其replace为eclipse的插件文件夹。

编辑

仅供参考,AOSP的问题跟踪器中已经发现了一个错误。

问题78436:[ADT / Eclipse]无法在“Android设备select器”对话框中看到我的设备,即使它在“设备”视图中

在这个页面的底部,有一个“为这个问题投票”的链接…

我可以通过连接一个真实的设备来解决这个问题。

请向下滚动,查看连接到ADB的设备列表。 在这里输入图像说明

在这里输入图像说明

我有一个类似的问题,但我的问题是模拟设备运行Android 4.3(SDK版本18),但该应用程序有android:minSdkVersion="19" ,因为没有find兼容的设备列表是空的。

仔细检查您的模拟设备版本和minSdkVersion编号,确保它是兼容的。