无法为Google应用邀请生成项目

我正在尝试这个Google应用程序邀请的东西,但我不能得到它的工作。

我遵循https://developers.google.com/app-invites/android/guides/appbuild议的步骤,但我很快就遇到了没有find“com.google.gms:google-services:1.0”等问题我跟随错误:无法findcom.google.gms:谷歌服务:1.0。 当在android工作室 build.gradle 添加谷歌服务插件和gradle继续build立,但后来我填写了这个错误:

在这里输入图像说明

我遵循这个答案: Android Studio:未能完成gradle执行,原因是空的 ,甚至尝试使用选项-Xmx512m,但问题仍然存在…任何有类似的问题,试图build立应用程序邀请邀请在他们的应用程序,不能甚至build立这个项目?

编辑:我没有设法解决这个问题,但我设法让应用程序邀请工作。 我不需要从App Invites谷歌指南中执行这些步骤:

将依赖关系添加到您的项目的顶级build.gradle:classpath'com.google.gms:google-services:1.3.0-beta1'将该插件添加到您的应用程序级别build.gradle:apply plugin:'com.google .gms.google的服务。

就像这样,gradle不会失败,因为我只需要添加谷歌播放服务依赖到应用程序级build.gradle文件。

我通过不包括整个播放服务来解决这个问题。 代替:

编译'com.google.android.gms:play-services:7.5。+'

键入这个:

编译'com.google.android.gms:play-services-appinvite:7.5。+'

顺便说一下,你说你不使用谷歌服务插件解决了你的问题。 你有没有检查你能发送邀请? 如果插件不加载configuration文件,它是如何工作的?

尝试将其更改为com.google.gms:google-services:1.3.0-beta1 。 这是什么样的作品。

尝试检查您的build.gradle文件中的存储库。 似乎依赖关系是在jcenter而不是mavencentral。 用jcenter()replacemavenCentral()。 这对我有效。