Google Play服务已过期。 需要3025100但find2012110

我在我的应用程序中使用Google maps v2并在模拟器中进行调试。 自从2月26日更新后,我现在收到此错误消息

Google Play services out of date. Requires 3025100 but found 2012110 

我现在想知道是否有人在模拟器中运行google play services rev 5所需的更新文件? 我尝试使用第4版Google Play服务运行应用程序,但模拟器没有它,并要求我更新Google Play服务。 有没有人有任何其他想法?

非常感谢

我find了我最终需要的文件, gms和vending

在ADT 22.0.1和新的Android私有库更新后,谷歌地图服务正在提供一些或错误和应用程序崩溃。 所以我最终find了解决方案,它对我有用。

只需安装google play服务lib,然后从以下链接转到google-play-service / libproject / google-play-services_lib: –

https://www.dropbox.com/sh/2ok76ep7lmav0qf/9XVlv61D2b

而不是导入到您的工作区。 清理你想要使用gogole-play-services-lib的项目而不是构建agian并转到Project> Properties> Java BuildPath>选择“Android Private Libraries,android Dependencies,google-play-service”

在属性本身转到Android,然后选择任何版本,然后选择添加并选择google-play-service-lib,然后按应用,最后确定。

最后转到项目> Android工具> Android支持库。 接受许可证并在安装后运行您的项目。

它会很好。

希望这会帮助你。