我的应用程序依赖于Google Play服务,而您的设备不支持。 联系制造商寻求帮助

我正在创build4.4.2(API 19)上的Google Map应用程序,并在4.4.2(API 19)下添加了所有Google Play服务,Google存储库和所有包。 但是我得到这个错误:

我的应用程序依赖于Google Play服务,而您的设备不支持。 联系制造商寻求帮助。

Solutions Collecting From Web of "我的应用程序依赖于Google Play服务,而您的设备不支持。 联系制造商寻求帮助"

可能的scheme

  1. 确保您使用的是最新版本的Google Play服务,最重要的是您的Play服务没有被禁用。 你可以在这里下载最新版本,

https://play.google.com/store/apps/details?id=com.google.android.gms

卸载之前更新的任何更新,然后再安装新的

转到 – >设置 – >应用程序 – >谷歌播放服务 – >卸载安装的更新

  1. 确保您的当前date/时间是正确的。

更新的答案:

如果您正在使用模拟器,请记住模拟器默认情况下不支持Google Play服务 。 您可以从SDK Manager下载并安装Google API ,然后使用Google API作为目标在模拟器中创build一个新设备。

首先从SDK Manager安装Google API,

在这里输入图像说明

像这样创build一个虚拟设备,

对于Android Studio,

在这里输入图像说明

对于Eclipse,

在这里输入图像说明