Google Play服务版本5.2.08对我的设备来说太近了

我使用这种方法来检查播放服务的可用性:

private boolean checkPlayServices() { int status = GooglePlayServicesUtil.isGooglePlayServicesAvailable(this); if (status != ConnectionResult.SUCCESS) { if (GooglePlayServicesUtil.isUserRecoverableError(status)) { showErrorDialog(status); } else { Toast.makeText(this, "This device is not supported.", Toast.LENGTH_LONG).show(); finish(); } return false; } return true; } 

status现在设置为2,当我运行的应用程序,表明已安装的播放服务需要更新,即使播放存储没有存储更新的播放服务。

isUserRecoverableError调用的对话框显示:

更新Google Play服务 – 除非您更新Google Play服务,否则此应用将无法运行

这是在我通过更新“Google Repository”的SDK Manager更新我的Android SDK之后发生的(如果我没记错的话,Google Play Services,尽pipe昨天没有任何问题,但是更新了)。

Android Studio告诉我,播放服务版本是5.2.08。

我能做什么? 我可以例如强制依赖部分的较低版本?

 compile 'com.google.android.gms:play-services:+' 

Solutions Collecting From Web of "Google Play服务版本5.2.08对我的设备来说太近了"