Google Play开发者控制台错误:您APK的版本代码很高,您可能无法更新您的APK

我正在尝试将我的应用更新到Google Play商店。 我有应用程序的当前版本号设置为2000000000,并想更新到2000000001.请不要问我为什么有这样的版本号select。

在这里输入图像说明

当我尝试推送新版本时,我收到了以下错误消息:“上传失败APK的版本代码很高,您可能无法更新您的APK。” 我不明白的一点是,根据官方的谷歌文件,最大版本号是MAXINT,2147483647,所以我还剩下大约150万个版本。 另一件事,我设法更新其他应用程序与相同的版本编号惯例,应用程序是在同一个开发帐户,我没有这样的错误。

在这里输入图像说明

我几次检查所有的数字,以确保我没有做一些愚蠢的错字。 我也已经联系了Google的支持,但也许这里有人有某种解决scheme?

Solutions Collecting From Web of "Google Play开发者控制台错误:您APK的版本代码很高,您可能无法更新您的APK"

Google的支持回应了我的要求。 他们将最大可用版本代码更改为2000000000,并且在发布这个问题时没有更新文档 (现在仍然是MAXINT:2147483647 )。 在这里有一个很好的例子,但也许有人会觉得这很有用。

看起来像文档中有一个更新08/11/2016(UTC)。 不是旧的MAX_INT值或2000000000。

警告:Google Play允许versionCode最大值为2100000000