Gradle:无法创buildAppPlugintypes的插件

我似乎无法用Gradle构build我的Android应用程序。

的build.gradle

buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } dependencies { compile 'com.intellij:annotations:12.0' } android { compileSdkVersion 19 buildToolsVersion "19" defaultConfig { minSdkVersion 14 targetSdkVersion 19 versionCode = 82 versionName = "0.6.1" } sourceSets { main { manifest.srcFile 'AndroidManifest.xml' java.srcDirs = ['src'] resources.srcDirs = ['src'] aidl.srcDirs = ['src'] renderscript.srcDirs = ['src'] res.srcDirs = ['res'] assets.srcDirs = ['assets'] } xposedmodule { manifest.srcFile 'xposed/AndroidManifest.xml' java.srcDirs = ['xposed/src'] resources.srcDirs = ['xposed/src'] aidl.srcDirs = ['xposed/src'] renderscript.srcDirs = ['xposed/src'] res.srcDirs = ['xposed/res'] assets.srcDirs = ['xposed/assets'] } } /* compileOptions { sourceCompatibility JavaVersion.VERSION_1_7 targetCompatibility JavaVersion.VERSION_1_7 }*/ signingConfigs { release } buildTypes { release { signingConfig signingConfigs.release } } } // ~/.gradle/gradle.properties if (project.hasProperty('keystoreFile') && project.hasProperty('keystorePassword') && project.hasProperty('keystoreAliasPassword')) { android.signingConfigs.release.storeFile = file(keystoreFile) android.signingConfigs.release.storePassword = keystorePassword android.signingConfigs.release.keyPassword = keystoreAliasPassword android.signingConfigs.release.keyAlias = keystoreAlias } else { android.buildTypes.release.signingConfig = null } //http://stackoverflow.com/questions/16683775/include-so-library-in-apk-in-android-studio tasks.withType(com.android.build.gradle.tasks.PackageApplication) { pkgTask -> pkgTask.jniDir new File(buildDir, 'native-libs') } 

我使用Gradle 1.10,发出这个命令时出现以下错误:

 gradle build.gradle --refresh-dependencies 

错误:

 Could not create plugin of type 'AppPlugin' 

Solutions Collecting From Web of "Gradle:无法创buildAppPlugintypes的插件"

哎呀,显然我使用的是Gradle的错误版本。 我的错!

这2 行可以清楚地说明使用的是什么版本

 println GradleVersion.current().prettyPrint() assert gradle.gradleVersion >= "1.10" // android plugin 0.10 requires Gradle 1.10, 1.11, 1.12 

在我的情况下,以pipe理员身份运行cmd.exe并在cmd控制台中inputgradle命令,错误消失。