以下软件包不可用: – 软件包ID lldb; 3.0 – Android Studio 3.0

我尝试debugging应用程序时出现此错误。 我已经尝试了这个链接中提到的步骤,但他们不工作。 我正在使用Windows。

Android Studio 2.2.2 LLDB 2.2更新问题

我检查了SDK Tools没有更新LLDB。 还尝试删除现有的LLDB文件夹并重新安装。 它需要3.0版本,但无处可寻。

Solutions Collecting From Web of "以下软件包不可用: – 软件包ID lldb; 3.0 – Android Studio 3.0"

Google忘了在稳定频道上提供lldb 3.0。 切换到Canary,通过SDK Manager更新lldb而不更新Android Studio本身,然后切换回您的首选频道(稳定版或testing版)。

除了MaxEd的回答,切换到Canary通道,请按照https://stackoverflow.com/a/32314026/8568479中的build议转到File > Settings > Appearance & Behavior > System Settings > Updates

有关于这个问题的错误报告,你可以在这里跟踪它的进度