Ionic2最低的iOS和Android版本

Ionic2(testing版)支持Android 4.4及更高版本,但我了解使用CrossWalk可以支持早期版本(但哪些?) https://forum.ionicframework.com/t/ionic-v2-latest-version-is-not-working -with-的Android-4-2-2 / 50611

我还没有设法find最低的iOS版本 – 这也是最受欢迎的。 我可以运行iOS 7(如目前的离子)?

祝一切顺利

Solutions Collecting From Web of "Ionic2最低的iOS和Android版本"

按照说明,cordova 4.0支持iOS 8。

要求和支持

构buildiOS应用程序所需的Apple®工具只能在基于Intel的Mac上的OS X操作系统上运行。 Xcode®6.0(最低要求版本)仅在OS X 10.9(Mavericks)或更高版本上运行,并包含iOS 8 SDK(软件开发工具包)。 To submit apps to the Apple App Store℠ requires the latest versions of the Apple tools.

您可以使用iOS SDK和Xcode安装的iOS模拟器来testingCordova的许多function,但是在提交到App Store之前,您需要一个实际的设备来全面testing所有应用程序的设备function。 The device must have at least iOS 8 installed, the minimum iOS version supported as of Cordova 4.0.0. 支持的设备包括iPhone 4S,iPhone 5,iPhone 5C,iPhone 5S,iPhone 6,iPhone 6 Plus,iPhone 6S,iPhone 6S Plus,iPhone SE,iPad 2,iPad 3,iPad 4,iPad Air,iPad Air 2,iPad Pro ,iPad Mini,iPad Mini 2,iPad Mini 3,iPod Touch第五代和iPod Touch第六代或更新版本。

参考: https //cordova.apache.org/docs/en/latest/guide/platforms/ios/

另一个参考是这个离子文档的链接 ,也有离子v2提到。

Ionic 1 Ionic V1专注于构build原生/混合移动应用程序,而不是移动网站。

因此,我们的浏览器支持往往是任何Web View API可用于给定平台上的本机应用程序。 对于Ionic 1x,这意味着iOS 7+的UIWebView和Android 4.1及更高版本。 我们build议使用Crosswalk来提高旧设备的性能。

Ionic 2 Ionic 2专注于通过Cordova构build本地/混合应用程序,并增加Progressive Web Apps和Electron的function。

支持以下操作系统和浏览器:

iOS 8+ Windows 10通用应用程序Android 4.4+如果Crosswalk与Cordova一起使用,支持可以推回到4.1