为什么我仍然得到java.lang.NoClassDefFoundError:android.support.v7.appcompat.R $ attr?

所以我正在开发一个俗气的应用程序,使之在我的公司真正的应用程序项目上工作之前,让自己在Android中进行自我训练。 我遇到了一个让我非常困难的bug。

我得到了一个我要使用的库依赖关系列表,并将我的build.gradle文件设置为加载它。它同步很好,所以我认为这是完全正确的:

dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.1.1' compile 'com.google.android.gms:play-services:7.3.0' compile 'com.squareup.okhttp:okhttp:2.3.0' compile 'com.squareup.retrofit:retrofit:1.7.0' compile 'com.google.code.gson:gson:2.3' compile 'com.squareup.dagger:dagger:1.2.2' compile 'com.squareup.dagger:dagger-compiler:1.2.2' compile 'com.squareup.picasso:picasso:2.5.2' compile 'com.android.support:recyclerview-v7:22.1.1' compile 'com.squareup:otto:1.3.7' compile 'com.path:android-priority-jobqueue:1.1.2' compile 'io.realm:realm-android:0.80.1' compile 'com.jakewharton:butterknife:6.1.0' compile 'com.android.support:multidex:1.0.0' compile 'com.android.support:appcompat-v7:22.1.1' } 

而且我实际上已经安装了android支持库和存储库: SDK管理器证明我已经安装了我需要的东西

但我仍然尝试启动应用程序,并获得以下堆栈跟踪:

 java.lang.NoClassDefFoundError: android.support.v7.appcompat.R$attr at android.support.v7.app.AppCompatDelegateImplV7.ensureSubDecor(AppCompatDelegateImplV7.java:286) at android.support.v7.app.AppCompatDelegateImplV7.setContentView(AppCompatDelegateImplV7.java:246) at android.support.v7.app.AppCompatActivity.setContentView(AppCompatActivity.java:106) at com.anglersatalas.twitstagram.MainActivity.onCreate(MainActivity.java:23) at android.app.Activity.performCreate(Activity.java:5451) at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1093) at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2298) at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2392) at android.app.ActivityThread.access$900(ActivityThread.java:169) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1280) at android.os.Handler.dispatchMessage(Handler.java:102) at android.os.Looper.loop(Looper.java:146) at android.app.ActivityThread.main(ActivityThread.java:5487) at java.lang.reflect.Method.invokeNative(Native Method) at java.lang.reflect.Method.invoke(Method.java:515) at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1283) at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1099) at dalvik.system.NativeStart.main(Native Method) 

在堆栈溢出的其他地方我见过的解决scheme是添加appcompat v7库,就像他们在android网站上所做的那样,我已经在上面演示了这些。 我无法弄清楚为什么还在发生。 查看堆栈跟踪,它在我的MainActivity中的setContentView()方法中断开:

 package com.anglersatalas.twitstagram; import android.os.Bundle; import com.anglersatalas.twitstagram.R; import android.support.v7.app.AppCompatActivity; import android.view.Menu; import android.view.MenuItem; import android.widget.TextView; import com.anglersatalas.twitstagram.api.PostService; import com.anglersatalas.twitstagram.models.Post; import java.util.List; import retrofit.RestAdapter; public class MainActivity extends AppCompatActivity{ @Override protected void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(com.anglersatalas.twitstagram.R.layout.activity_main); TextView tv = (TextView)findViewById(com.anglersatalas.twitstagram.R.id.textView); RestAdapter adapter = new RestAdapter.Builder() .setEndpoint("10.0.0.248/testserver/backend/web") .build(); PostService service = adapter.create(PostService.class); List<Post> list = service.getPosts(); String str = ""; for(Post p : list){ str += String.format("%s\n", p); } tv.setText(str); } ... } 

点击正在调用引发exception的方法的类文件,显示它找不到'android.support.v7.appcompat.R;':

在这里输入图像说明

我的同事和我都不知所措 任何build议如何补救?

Solutions Collecting From Web of "为什么我仍然得到java.lang.NoClassDefFoundError:android.support.v7.appcompat.R $ attr?"

我只是花了几个小时,这个问题,我能够得到解决…

事实certificate,我超过了dex的限制,我在defaultConfig下的build.gradle文件中有multiDexEnabled为true,但是看起来我缺less了pre 5.0设备的其他一些东西。

 defaultConfig { ... multiDexEnabled true ... } 

我首先检查了我的方法数: https : //github.com/mihaip/dex-method-counts

我在67952方法…

然后我更新了我的build.gradle以添加multidex支持

 dependencies { ... compile 'com.android.support:multidex:1.0.0' ... } 

然后,我更新了我的应用程序(我们已经有自己的),从MultiDexApplication扩展

 package com.me.myapp ... public class Application extends MultiDexApplication {} 

以下是我用来正确实现multidex的文档中的两个链接: https : //developer.android.com/tools/building/multidex.html https://developer.android.com/reference/android/support/multidex/ MultiDexApplication.html

确保清单中的应用程序指向您的自定义multidex应用程序

 <application ... android:name="com.me.myapp.Application" /> 

我只花了几个小时,现在解决了。

某些Android应用程序的约束是底层编译的.dex文件可以支持的方法的总数。 它受16位或65,536个值的限制。

在应用程序中包含第三方库时,您将在.dex文件中包含所有方法。 较大的API,例如Google Play服务中包含的API,将很快开始进入极限。

有关详细信息: Google Play服务和DEX方法限制

在我的情况下,我在我的应用程序中使用Google Play / Google Youtube身份validation服务。

编译“com.google.android.gms:play-services:7.3.0”

所以我改变了

编译“com.google.android.gms:play-services-identity:7.3.0”

因为我只要求身份validation的目的。 所以你可以根据你的要求select个人图书馆。

例如,如果您要使用的是“ 地图” ,则您将拥有:

编译“com.google.android.gms:play-services-maps:7.3.0”

同样的位置

编译“com.google.android.gms:play-services-location:7.3.0”

我希望它会帮助你!