java.lang.NullPointerException(无错误消息)APK构建

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { maven { url "https://plugins.gradle.org/m2/" } jcenter() } dependencies { classpath "gradle.plugin.me.tatarka:gradle-retrolambda:3.3.0" classpath 'com.android.tools.build:gradle:2.2.1' } } allprojects { repositories { jcenter() mavenCentral() } } task clean(type: Delete) { delete rootProject.buildDir } 

:app文件

 apply plugin: 'me.tatarka.retrolambda' apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "24.0.3" compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } defaultConfig { applicationId "it.univpm.gruppoids.iotforemergencyandnavigation" minSdkVersion 16 targetSdkVersion 23 versionCode 1 versionName "1.0" jackOptions { enabled true } } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.android.support:design:23.4.0' compile 'com.android.support:support-v4:23.4.0' compile 'com.journeyapps:zxing-android-embedded:3.2.0@aar' compile 'com.google.zxing:core:3.2.1' compile 'org.jgrapht:jgrapht-core:1.0.0' } 

当我尝试构建APK时,它向我显示:错误:配置项目’:app’时出现问题。

java.lang.NullPointerException(无错误消息)

这是版本的问题吗? 或与lamdas? 有人可以帮帮我吗?

添加后我遇到了同样的问题:

 compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } 

这是因为我的默认java版本是10:

 $ java -version java version "10.0.1" 2018-04-17 

更改为1.8(使用sudo update-alternatives –config java )后问题得到修复。

这些天我遇到了同样的问题。 我发现它可能是由gradle版本引起的。 将版本更改为2.1.0后,问题就消失了。

 dependencies { classpath 'com.android.tools.build:gradle:2.1.0' } 

我不确定它对你有用。

将其添加到app模块的build.gradle文件中:

 lintOptions { checkReleaseBuilds false } 

看到另一个问题 :虽然这在Retrolambda文档中有说明,但在使用Retrolambda时,不应将JAVA版本指定为1.8。 因此,不再需要将插孔支持设置为true。 这对我有用。

只需删除包含.gradle文件夹下的项目,然后重新启动android studio。 它由谷歌开发者页面测试和批准。 它100%工作。