Libgdx设置UI在新GWT项目中出现2个意外错误

我已经运行了设置ui,但是,我在-html项目中得到的两个错误比教程中描述的错误: libgdx教程

声明的教程错误如下(这是我看不到的错误):

要修复HTML5 / GWT项目的错误,请转到“问题”视图,右键单击错误消息“WEB-INF / lib目录中缺少GWT SDK JAR gwt-servlet.jar”并选择“快速修复” ”。 单击“完成”。

我遇到的错误是:

该项目未构建,因为其构建路径不完整。 找不到com.google.gwt.core.client.EntryPoint的类文件。 修复构建路径然后尝试构建此项目…

无法解析com.google.gwt.core.client.EntryPointtypes。 它是从所需的.class文件间接引用的

无论如何我能解决这个问题吗? 我刚刚更新了我的日食,我还下载了版本18 ADT,Android SDK工具版本19和Android SDK平台工具版本11。

  • 如何检测设备在libGDX中的颠倒方向
  • 在LibGDX中模糊屏幕
  • 如何使用libGDX设置纵向模式?
  • libgdx - 如何在舞台上添加背景图片?
  • libgdx中Actor的动作
  • 在Libgdx中绘制渐变
  • 'sourceSets'无法应用于Android Studio中的'groovy.lang.closure'警告
  • 在Android上使用libGDX的SQLite
  • 几周前我遇到了同样的问题,并通过安装GWT SDK解决了这个问题。

    我知道post很旧,但是虽然@Rod的答案已接近解决我的问题,但它并没有完全解决。 在他的回答中安装插件后,我收到了3条错误消息,而不是两条错误消息:相同的先前消息和新消息。

    查看提出问题的类内部使Eclipse直接指出问题:编译器合规性要求为1.5或更高,但Eclipse默认为1.4。 我通过“ 窗口”>“首选项”>“Java”>“编译器”>“编译器合规性级别”更改了它,我在其中放置了正确的1.7,并且所有内容都编译得很干净。

    PS:谢谢@Rod

    使用http://dl.google.com/eclipse/plugin/4.2在eclipse上安装插件

    而不是http://dl.google.com/eclipse/plugin/ 4.4或4.3