无法parsingAndroid Studio 2.3.3中的“com.google.firebase:firebase-messaging:11.0.4”

我想在Android studio上设置firebase云消息客户端应用程序,我正在使用最新版本的Android studio(2.3.3),我的android SDK已经完全更新。

这是我的项目gradle文件:

buildscript { repositories { jcenter() } dependencies { classpath 'com.google.gms:google-services:3.1.0' classpath 'com.android.tools.build:gradle:2.3.3' } } allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } task clean(type: Delete) { delete rootProject.buildDir } 

这是我的应用程序构buildgradle文件:

 apply plugin: 'com.android.application' android { compileSdkVersion 25 buildToolsVersion "25.0.3" defaultConfig { applicationId "ir.digiwindow.driver.gps_status" minSdkVersion 14 targetSdkVersion 25 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:25.3.1' compile 'com.android.support.constraint:constraint-layout:1.0.0-alpha7' testCompile 'junit:junit:4.12' compile 'com.google.firebase:firebase-messaging:11.0.4' } apply plugin: 'com.google.gms.google-services' 

我总是给这个错误:

 Error:(30, 13) Failed to resolve: compile 'com.google.firebase:firebase-messaging:11.0.4' 

这里值得一提的是,当我将版本从11.0.4更改为10.0.1时,没有发生错误,并且gradle build成功! 我阅读所有在stackoverflow和谷歌开发人员网站相关post,但这个错误仍然存​​在! 任何想法欢迎…

编辑1:当我去寻找更新,我没有看到有关更新谷歌播放服务在这里的任何选项图像: enter image description here

Solutions Collecting From Web of "无法parsingAndroid Studio 2.3.3中的“com.google.firebase:firebase-messaging:11.0.4”"

我面临同样的问题,我已经解决了更新两件事情

  1. Google Play服务
  2. Google资料库

在这里输入图像说明

Jan先生,请按照下面的链接清楚地说明 – >

https://firebase.google.com/docs/android/setup#Prerequisites

Prerequisites-

  • 运行Android 4.0(冰淇淋三明治)或更新的设备,以及Google Play服务11.6.0或更高版本
  • 来自Google Repository的Google Play服务SDK,可在Android SDK Manager中find
  • Android Studio的最新版本,版本为1.5或更高版本

所以请像下面的步骤一样在SDKpipe理器中升级您的谷歌播放服务和Google储存库

打开Android studio>进入文件>设置>外观和行为>系统设置> Android SDK> SDK工具>更新

1- Google播放服务和

2-系统存储库下的Google存储库

正如文档中提到的Dileep,您需要安装Google Play服务11.0.4或更高版本。

只需打开SDKpipe理器,
然后Android SDK(在左边的菜单上)
然后转到SDK Tools标签并更新当前版本为43(2017-08-10)的Google Play服务。

这为我解决了。

尝试通过Firebase Assitance添加Firebasefunction转到工具,然后selectFirebase,然后select要添加的function,例如实时数据库。 它会自动将编译依赖项添加到您的项目中。 我也这样做,解决了我的问题。

我有同样的问题,我只是将版本11:0:4更改为10:0:1,错误消失了。 只是尝试可能有帮助。