无法parsing:com.android.support:appcompat-v7:25.1.0

在这里输入图像说明 我的Android Studio是充满错误的android studio无法识别库。

Error:(27, 13) Failed to resolve: com.android.support:appcompat-v7:25.1.0 

Solutions Collecting From Web of "无法parsing:com.android.support:appcompat-v7:25.1.0"

确保存储库部分包含“ https://maven.google.com ”端点的maven部分。 例如:

 allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

有关详细信息,请参阅android文档

通过点击自动安装最新的库存在问题

安装存储库和同步项目

转到SDK Manager,从下面的选项卡安装缺less的或不是最新的软件包:

在这里输入图像说明

select所需库之后,单击应用并等待安装完成。

点击链接

“安装存储库和同步项目”

最近你说了一些问题。 我解决这个问题如下:

第1步。在AndroidStudio中创build一个新的Android项目,它可以正常运行。

第2步。请确保您的项目可以正常运行,并查看build.gradle文件,然后在build.gradle文件中find版本代码。 而我的build.gradle文件如下所示:

 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion 24.0.1 } ... ... dependencies { // App's dependencies, including test compile "com.android.support:appcompat-v7:23.4.0" compile "com.android.support:cardview-v7:23.4.0" } 

而正确的版本23.4.0是你想要的。

如果你不能解决问题,你可以改变compileSdkVersion和buildToolsVersion

第3步。在build.gradle文件和同步项目中configuration正确的版本。

  1. 首先将buildToolsVersion版本23.0.1更改为25.0.1
  2. 设置compileSdkVersion 25

最后

 compileSdkVersion 25 buildToolsVersion "25.0.1" 

确保你更新你的支持库 。 然后清理 – 重build – 运行

首先,你会去(your_folder_app)\ app \ app.iml,它打开你的记事本软件。 之后你会发现:你用你的版本更改为27,例如对我来说,我改为25。

其次,你会改变你的android studio build.gradle(Moudule:应用程序)。 红色的箭头表明你应该改变。 在这里input图像说明 。 我的例子: 在这里input图片描述

最后,你会点击“再试一次”

在allprojects {}中添加以下代码到您的项目级gradle

  maven { url "https://maven.google.com" }