无法parsing:com.google.android.gms:play-services-measurement:9.6.1

今天,我更新了所有支持库和buildtools到最新版本,以支持Android N 一旦我更新了所有内容并运行了应用程序,在我的应用程序中出现了GCM InstanceId生成方法错误。 所以,我search并find解决scheme,build议更新播放服务。 在遵循所有的问题和答案后,我被卡住了,不能前进。 切换回支持库23.xx是不是一个选项,因为我想要的目标Android N

下面是我的项目级build.gradle文件的外观:

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.2.0' classpath 'com.google.gms:google-services:3.0.0' } } allprojects { repositories { jcenter() } } 

应用程序级别build.gradle

 buildscript { repositories { mavenCentral() maven { url 'https://maven.fabric.io/public' } // maven { url 'http://hansel.io/maven' } maven { url "https://jitpack.io" } } dependencies { classpath 'io.fabric.tools:gradle:1.+' // classpath 'io.hansel.preprocessor:preprocessor:1.0.+' } } apply plugin: 'com.android.application' apply plugin: 'io.fabric' //apply plugin: 'io.hansel.preprocessor' android { compileSdkVersion 24 buildToolsVersion "24.0.2" signingConfigs { } defaultConfig { applicationId 'com.example.android' multiDexEnabled true minSdkVersion 16 targetSdkVersion 24 versionCode 47 versionName "1.3.2" renderscriptTargetApi 24 renderscriptSupportModeEnabled true } buildTypes { debug { applicationIdSuffix = ".dev" resValue "string", "app_name", "example-debug" } release { minifyEnabled false shrinkResources false resValue "string", "app_name", "example" proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } productFlavors { dev { // dev utilizes minSDKVersion = 21 to allow the Android gradle plugin // to pre-dex each module and produce an APK that can be tested on // Android Lollipop without time consuming dex merging processes. minSdkVersion 21 } prod { // The actual minSdkVersion for the application. minSdkVersion 16 } } dexOptions { javaMaxHeapSize "4g" } } repositories { mavenCentral() mavenLocal() jcenter() maven { url 'https://maven.fabric.io/public' } maven { url "https://jitpack.io" } // maven { url 'http://hansel.io/maven' } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.android.support:appcompat-v7:24.2.1' compile 'com.android.support:support-v4:24.2.1' compile 'com.android.support:support-annotations:24.2.1' compile 'com.squareup.picasso:picasso:2.5.2' compile 'com.android.support:design:24.2.1' compile 'com.facebook.android:facebook-android-sdk:4.3.0' compile 'com.squareup.okhttp:okhttp:2.4.0' compile 'com.squareup.okhttp:okhttp-urlconnection:2.4.0' compile 'com.android.support:recyclerview-v7:24.2.1' compile 'com.android.support:cardview-v7:24.2.1' compile 'com.squareup.retrofit:retrofit:1.9.0' compile 'com.jakewharton:butterknife:7.0.1' compile 'com.github.clans:fab:1.6.1' compile 'com.facebook.fresco:fresco:0.8.1+' compile 'com.facebook.fresco:imagepipeline-okhttp:0.8.1+' compile 'uk.co.chrisjenx:calligraphy:2.1.0' compile 'com.google.android.gms:play-services-analytics:9.6.1' compile 'com.google.android.gms:play-services-location:9.6.1' compile 'com.google.android.gms:play-services-gcm:9.6.1' compile 'com.google.android.gms:play-services-measurement:9.6.1' compile 'com.github.liuguangqiang.swipeback:library:1.0.2@aar' compile 'me.imid.swipebacklayout.lib:library:1.0.0' compile 'com.github.2359media:EasyAndroidAnimations:0.8' compile 'com.theartofdev.edmodo:android-image-cropper:2.0.+' compile 'com.wang.avi:library:1.0.1' compile 'com.nineoldandroids:library:2.4.0' compile 'com.mixpanel.android:mixpanel-android:4.6.4' compile 'com.github.ppamorim:dragger:1.2' compile 'io.reactivex:rxandroid:1.1.0' compile 'io.reactivex:rxjava:1.1.3' compile 'com.jakewharton.rxbinding:rxbinding:0.2.0' // debugCompile 'com.squareup.leakcanary:leakcanary-android:1.4-beta2' // releaseCompile 'com.squareup.leakcanary:leakcanary-android-no-op:1.4-beta2' compile 'com.bignerdranch.android:expandablerecyclerview:2.1.1' compile 'com.android.support:multidex:1.0.1' compile 'com.birbit:android-priority-jobqueue:2.0.0' compile 'com.squareup:otto:1.3.8' compile 'com.mikhaellopez:circularprogressbar:1.1.1' compile 'com.github.dotloop:aosp-exif:be25ae51ec' compile('com.crashlytics.sdk.android:crashlytics:2.5.5@aar') { exclude group: 'com.squareup.okhttp', module: 'okhttp' transitive = true; } } apply plugin: 'com.google.gms.google-services' 

这是我得到的错误: 在这里输入图像说明

任何帮助将不胜感激。 谢谢。

编辑

我的谷歌播放服务也被更新。 在这里输入图像说明

Solutions Collecting From Web of "无法parsing:com.google.android.gms:play-services-measurement:9.6.1"

今天我有同样的问题。 这解决了我的问题:

打开独立的Android SDKpipe理器。 在附加部分中,“Google Play服务”是最新版本,但在将“Google Repository”从版本33更新到35之后的“Google Repository”中,问题消失了。

你没有最新的谷歌播放服务,只需点击链接,Android工作室将提供一个对话框来安装它。

将所有播放服务依赖关系设置为9.6.0。 9.6.1还没有发布。 如果问题仍然存在,请在您的android studio中安装最新的Google Play服务和存储库。

最后,我自己解决了。 这是我做的:

  1. 删除了compile 'com.google.android.gms:play-services-measurement:9.6.1' ,然后编译该项目
  2. 它提供missing api_key error因为GCM被转移到Firebase ,所以google-services.json文件不起作用
  3. 要解决这个问题,只需使用从Firebase使用云消息传递的新生成的文件更新google-services.json文件即可
  4. 在此之后,我编译了另一个错误,因为我使用的是自动填充API,因此项目中缺less@drawable/powered_by_google_dark 。 要解决这个问题,请将compile 'com.google.android.gms:play-services-places:9.6.0'到依赖关系