PhoneGap开发应用程序下载错误

我正在使用PhoneGap开发应用程序来即时testing我的应用程序,并从今晚开始,该应用程序显示“下载”,然后几秒钟后显示“下载错误”。 之后,出现一个popup窗口

Unable to download archive from the server. Please upgrade the PhoneGap CLI or check your network settings.

那么,如何升级PhoneGap CLI以及我应该检查哪些设置? 我没有改变任何networking设置和PhoneGap开发应用程序在我的Macbook和iPhone上工作正常,但现在它说这个。

有什么问题,我该如何解决?

编辑我现在意识到,这是现在发生的,因为PhoneGap开发人员的iOS应用程序已经更新(现在版本1.5.2)。 我已经将PhoneGap CLI升级到版本5.0.0-0.28.0,这是根据PhoneGap的博客文章推荐的版本

似乎桌面和移动应用程序现在进行沟通的新方式出现了问题。

Solutions Collecting From Web of "PhoneGap开发应用程序下载错误"

解决scheme:

从官方网站下载最新版本的PhoneGap桌面应用程序。 因此,您必须更新用于移动的PhoneGap开发人员应用程序,PhoneGap CLI并下载最新的PhoneGap桌面应用程序。

对于我从PhoneGap CLI启动本地服务器的帮助。 事情是,由于某种原因使用PhoneGap桌面不会触发一个特殊的Windows对话框来允许应用程序的一些操作。

您应该尝试在cmd窗口中手动运行命令phonegap serve来触发防火墙请求,以便通过Windows打开(如果您在Windows上)。 你也可以看到日志。 保持窗口打开。

我把这个端口从3000改成了其他的,并且工作。 可能有别的东西在听它。

在使用WiFi时,您的计算机和设备必须位于同一networking上。

我得到了同样的问题,并修复更新phonegap。

更新你的手机npm update -g phonegapsudo npm update -g phonegap如果需要root的话。

还要在手机中更新您的Phonegap CLI。

我不得不安装node.js ,它现在正在工作。