'不支持的模板依赖:用SDK Tools v22升级你的Android Eclipse插件'

我最近升级了我的Android SDK工具到版本22.但是,当我尝试在Eclipse中创build一个新项目时,我收到一条错误消息:

不受支持的模板依赖:升级您的Android Eclipse插件

我该如何解决这个问题?

http://dl-ssl.google.com/android/repository/tools_r22-windows.zip下载,解压缩并replace/ tools文件夹以降级sdk工具。 22版有个bug。

对于Mac http://dl-ssl.google.com/android/repository/tools_r22-macosx.zip

对于Linux: http : //dl-ssl.google.com/android/repository/tools_r22-linux.zip

该项目成员发表评论#55解决这个问题,而不下载SDK工具。 只需下载活动模板 ,并将sdk/tools/templates/activities文件夹replace为ZIP文件的内容即可。

您可能需要使用-clean选项重新启动Eclipse才能使用。

从Eclipse转到帮助>检查更新并安装Eclipse显示的任何更新。

一旦更新SDK组件,您通常也需要更新Eclipse插件。

当我升级到最新的Android SDK工具(22.2)时,我开始面临同样的问题。 所以我恢复了更改,现在使用Android SDK工具(22.0.5),它工作正常。

尝试降级Android SDK工具。