错误:SDK构build工具修订版(23.0.3)对于项目“:app”来说太低。 最低要求是25.0.0

标题是重复的,但我的问题是不同的。

同样的项目工作正常,并允许build立

buildToolsVersion 23.0.3

在我的同事的系统上。 据我所知,只有android studio版本是不同的。 如果我没有升级我的Android工作室到“2.3.Beta 2”,我仍然可以用23.0.3构build吗?

Solutions Collecting From Web of "错误:SDK构build工具修订版(23.0.3)对于项目“:app”来说太低。 最低要求是25.0.0"

你必须改变顶层的 build.gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.3.0' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files // classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8' } } allprojects { repositories { jcenter() } } 

至:

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.2.3' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files // classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8' } } allprojects { repositories { jcenter() } } 

如果我没有升级我的android studio到“2.3.Beta 2”,我仍然可以用23.0.3构build?

是。

您仍然可以使用任何版本的构build工具从命令行运行构build过程。

随意将构build工具升级到25.0.2(最新截至27.1.2017)。 这只会影响构build过程,不会影响应用程序的行为。

较新版本的构build工具包含更多选项和较新的技术,Android Studio的较新版本依赖于这些技术。

是的,你可以做2.3工作室是高达25支持你想在工作室安装SDK 19to25

当我的项目从Android Studio 1.5.0迁移到2.3.0时,设置classpath“com.android.tools.build:gradle:1.+”可以解决我的问题。

在这里input图像说明

模块 – > build.gradle-> buildToolsVersion-> 26.0.0 25.0.0不支持