使用Spotify SDK安装Android应用时出错,

我正在尝试使用Spotify Beta SDK的教程,并在尝试将应用程序安装到(Nexus 6)仿真器时不断收到此错误。 这是[INSTALL_FAILED_NO_MATCHING_ABIS]。 我使用的是与教程中相同的代码,我发现了一些关于ARM和Intel编译的内容,但是我不确定这是什么意思/如何使用这些信息。 谢谢!

Related of "使用Spotify SDK安装Android应用时出错,"

Spotify SDK仅包含用于ARM架构和ARM架构的本地库。

由于INSTALL_FAILED_NO_MATCHING_ABIS是由APK安装不支持的APK(即APK不包含设备的CPU架构的本机库)所导致的,我的猜测是您正试图在x86模拟器上运行它,而Spotify SDK不支持。

尝试创build一个ARM模拟器,它应该工作。

编辑:要为ARM创build仿真器configuration,请执行以下操作:

  1. 点击“AVD Manager” – >“Create Virtual Device”
  2. select“Nexus 6” – >“下一步”
  3. 用下面的armeabi-v7a ABIselect一个:

在这里输入图像说明