首选项支持库 – SwitchPreference不起作用

几天前Google推出了Preference Support Library ( Link )。 我只是试图在我的应用程序中实现它,虽然它似乎不与SwitchPreferences一起工作,这很奇怪,因为Google声明我们可以像以前一样使用相同的XML文件,并且明确地说SwitchPreferences现在可用于所有API 7+设备。

报价( 来源 )

并使用相同的首选项XML文件( http://goo.gl/wOcIxI )添加首选项,同时向所有API 7+设备添加对SwitchPreference(以前仅适用于API 14 +设备)等元素的支持。 […]

错误信息

 java.lang.RuntimeException: Unable to start activity ComponentInfo{com.my.package/com.my.package.Main}: android.view.InflateException: Binary XML file line #4: Error inflating class (not found)SwitchPreference at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2325) at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2387) at android.app.ActivityThread.access$800(ActivityThread.java:151) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1303) at android.os.Handler.dispatchMessage(Handler.java:102) at android.os.Looper.loop(Looper.java:135) at android.app.ActivityThread.main(ActivityThread.java:5254) at java.lang.reflect.Method.invoke(Native Method) at java.lang.reflect.Method.invoke(Method.java:372) at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:903) at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:698) 

相关部分显然是Binary XML file line #4: Error inflating class (not found)SwitchPreference

Java代码

 public class FragmentSettings extends PreferenceFragmentCompat { @Override public void onCreatePreferences(Bundle bundle, String s) { addPreferencesFromResource(R.xml.preferences); } } 

的preferences.xml

 <?xml version="1.0" encoding="utf-8"?> <PreferenceScreen xmlns:android="http://schemas.android.com/apk/res/android"> <SwitchPreference android:key="pref_something" android:summary="Lorem ipsum dolor sit amet" android:title="Lorem ipsum" /> </PreferenceScreen> 

所以基本上问题是:我做错了什么或者这是一个确定支持库的错误?

Solutions Collecting From Web of "首选项支持库 – SwitchPreference不起作用"