清单合并失败:uses-sdk:minSdkVersion 8不能小

问题是..

Error:Execution failed for task ':app:processDebugManifest'. 

清单合并失败:uses-sdk:minSdkVersion 8不能小于库中声明的版本L com.android.support:support-v4:21.0.0-rc1

build.gradle中的代码

  apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion "20.0.0" defaultConfig { applicationId "com.androidexample.gcm" minSdkVersion 8 targetSdkVersion 16 } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:support-v4:+' compile 'com.google.android.gms:play-services:+' //compile 'com.android.support:support-v4:20.0.0' //compile 'com.google.android.gms:play-services:5.0.77' } 

AndroidManifest中的代码是..

  <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.androidexample.gcm" android:versionCode="1" android:versionName="1.0" > <!-- GCM requires Android SDK version 2.2 (API level 8) or above. --> <uses-sdk android:minSdkVersion="8" android:targetSdkVersion="16" /> <!-- Main activity. --> <application android:name="com.androidexample.gcm.Controller" android:icon="@drawable/ic_launcher" android:label="@string/app_name" > <!-- Register Activity --> <activity android:name="com.androidexample.gcm.RegisterActivity" android:label="@string/app_name" > <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> <intent-filter> <action android:name="android.intent.action.VIEW" /> <action android:name="android.intent.action.DELETE" /> <category android:name="android.intent.category.DEFAULT" /> <data android:scheme="com.idrivecare.familypro" /> </intent-filter> </activity> <!-- Main Activity --> <activity android:name="com.androidexample.gcm.MainActivity" android:configChanges="orientation|keyboardHidden" android:label="@string/app_name" > </activity> <receiver android:name="com.google.android.gcm.GCMBroadcastReceiver" android:permission="com.google.android.c2dm.permission.SEND" > <intent-filter> <!-- Receives the actual messages. --> <action android:name="com.google.android.c2dm.intent.RECEIVE" /> <!-- Receives the registration id. --> <action android:name="com.google.android.c2dm.intent.REGISTRATION" /> <category android:name="com.androidexample.gcm" /> </intent-filter> </receiver> <service android:name="com.androidexample.gcm.GCMIntentService" /> <meta-data android:name="com.google.android.gms.version" android:value="@integer/google_play_services_version" /> </application> <!-- GCM connects to Internet Services. --> <uses-permission android:name="android.permission.INTERNET" /> <!-- GCM requires a Google account. --> <uses-permission android:name="android.permission.GET_ACCOUNTS" /> <!-- Keeps the processor from sleeping when a message is received. --> <uses-permission android:name="android.permission.WAKE_LOCK" /> <!-- Creates a custom permission so only this app can receive its messages. --> <permission android:name="com.androidexample.gcm.permission.C2D_MESSAGE" android:protectionLevel="signature" /> <uses-permission android:name="com.androidexample.gcm.permission.C2D_MESSAGE" /> <!-- This app has permission to register and receive data message. --> <uses-permission android:name="com.google.android.c2dm.permission.RECEIVE" /> <!-- Network State Permissions to detect Internet status --> <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" /> <!-- Permission to vibrate --> <uses-permission android:name="android.permission.VIBRATE" /> </manifest> 

谢谢你,先生..

Solutions Collecting From Web of "清单合并失败:uses-sdk:minSdkVersion 8不能小"

如果你使用

 'com.android.support:support-v4:+' 

假设它可以使用21.x,因为它是最新版本(但是与低于L的目标不兼容)

将其更改为

 'com.android.support:support-v4:20.+' 

所以它会下载最新的20.x版本

问题是因为你的app min sdk是8,你select使用Google Plus服务,需要min sdk 9。

将行“ minSdkVersion 8 ”更改为“ minSdkVersion 9 ”。 所以, 保存它

之后, 清理项目重build它

在我的情况下,我将build.gradle文件中的代码{minSdkVersion 8}更改为{minSdkVersion 9}



     defaultConfig {
             applicationId“com.example.npeducations.week1_lab”
             minSdkVersion 9
             targetSdkVersion 23
             versionCode 1
             versionName“1.0”
            }

现在它工作正常

 <uses-sdk tools:overrideLibrary="your pkg name of libary with conflict" /> 

并在AndroidManifest.xml中添加xmlns:tools =“http://schemas.android.com/tools&#x201D;

我不得不改变我的libGDX And​​roid Studio的android/build.gradle文件,所以看起来像这样,当我想要集成亚马逊移动广告库。

 android { buildToolsVersion "23.0.3" compileSdkVersion 23 sourceSets { main { manifest.srcFile 'AndroidManifest.xml' java.srcDirs = ['src'] aidl.srcDirs = ['src'] renderscript.srcDirs = ['src'] res.srcDirs = ['res'] assets.srcDirs = ['assets'] jniLibs.srcDirs = ['libs'] } instrumentTest.setRoot('tests') } defaultConfig { applicationId "com.foo.bar" // RBC minSdkVersion 8 minSdkVersion 9 targetSdkVersion 23 } } ... 

你可以运行简单的下面的命令。

 cordova build android -- --minSdkVersion=15 

它会为你工作。