使用谷歌地图V2或V3在Android应用程序?

我正在做一个Android上的旅游指南系统的项目。 我想在我的应用程序中包含谷歌地图,并想知道是否使用谷歌地图API V3或V2? 另外,我找不到任何教程告诉我如何包含v3。 任何帮助,将不胜感激。 谢谢

Solutions Collecting From Web of "使用谷歌地图V2或V3在Android应用程序?"

Google Maps API V2Google Maps API V2的本地版本,而Google Maps API V3是用于网站开发的新API,您可以使用API​​ V3并将其embedded到WebView ,但是如果您希望获得最佳结果,则应使用Google适用于Android的Maps API V2。

在这里,我写了一篇关于如何在您的应用程序中embeddedGoogle Maps API V2的博客指南,您可以使用它开始使用:

Google Maps API V2

适用于Android的Maps API的最新版本是v2,v3适用于networking。

https://developers.google.com/maps/documentation/android/

Google Maps API v2为android提供了特定的API。

为了web开发的API,Google Maps API v3的devise能够快速加载并在移动设备上运行良好。 特别是专注于Android和iOS手机等高级移动设备的开发。 GoogleMap的#手机

在webview和javascript界面​​中使用谷歌地图v3在Android。

在这里谷歌地图V3的博客指南,我写了如何在Android应用程序中使用谷歌地图API V3。

在2013年V2是有效的,但现在V3是最新的Android地图检查线程https://stackoverflow.com/a/41549359/2888952