versionCode / versionName错误

我的android工作室有这个奇怪的问题,当我尝试编译/运行/构建apk时,androidCode和androidName总是来到版本1.0,无论我设置它。 我一直在更改主AndroidManifest.xml文件,但仍然没有。 有没有其他人有这个错误,或者你做了什么修复它?

这是build.gradle是罪魁祸首,在android下,你需要在这里更改设置:

defaultConfig { minSdkVersion 9 targetSdkVersion 19 versionCode 2 <----This versionName "1.1" <----This } 

你需要在AndroidManifest中更改android:versionCodeandroid:versionName ,如下所示:

如果Old是:

   

将其更改为: