versionCode / versionName错误

我有我的android工作室这个奇怪的问题,当我尝试编译/运行/构buildapk的androidcode和androidName总是来版本1.0,无论我设置它。 我一直在改变主AndroidManifest.xml文件,仍然没有。 有没有其他人有这个错误,或者你做了什么来解决它?

  • 如何在Android Studio中包含来自其他模块的string
  • 菜单目录丢失
  • 错误重复条目:com / google / android / gms / location / places / zzj.class
  • Android Studio 0.2.9和新项目
  • 为什么Gradle只包含来自我的库的具有项目依赖性的类
  • NoClassDefFoundError android / support / v4 / animation / AnimatorCompatHelper
  • 无法启动Android工作室
  • 如何从android studio中的另一个模块导入类?
  • 这是build.gradle是罪魁祸首,在android下,你需要改变这里的设置:

    defaultConfig { minSdkVersion 9 targetSdkVersion 19 versionCode 2 <----This versionName "1.1" <----This } 

    您需要在AndroidManifest中更改android:versionCodeandroid:versionName ,如下所示:

    如果老是:

     <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.example.hello" android:versionCode="1" android:versionName="1.0" > 

    将其更改为:

     <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.example.hello" android:versionCode="2" android:versionName="1.1" >