在Visual Studio 2015中,应用程序不能在android的visual studio模拟器中运行

我创build空白xamarinandroid项目,而无需添加任何代码,当我debugging这个项目debugging没有问题,但是当我运行的应用程序与视觉工作室模拟器的android模拟器运行,但没有启动我的应用程序和部署失败,不显示我错误

为什么? 请帮帮我

Solutions Collecting From Web of "在Visual Studio 2015中,应用程序不能在android的visual studio模拟器中运行"

我遇到过同样的问题。 VS 2015可以启动VS模拟器,但无法部署应用程序。

我能够解决这个问题:

  1. 启动模拟器(VS中的F5,然后使用Build / Cancel菜单取消部署)
  2. 点击仿真器右侧工具栏中的人字形图标»
  3. selectnetworking选项卡
  4. find首选的networkingIP地址
  5. 回到VS,点击打开Adb命令提示符工具栏button
  6. 键入adb connect [模拟器IP地址]
  7. 在VS中再次按F5

看起来像一个VS的bug。

我遇到过同样的问题。 事实certificate,根本原因是VS模拟器无法findadb.exe。

发生这种情况时,除非按照CSharpRocks提供的步骤进行手动连接,否则将不会连接到仿真器。 仿真器也不会在“adb设备”下列出。

对我的修复是使用基于Windows EXE的安装程序(而不是zip安装程序)重新安装Android SDK。 EXE安装程序在registry中设置HKEY_LOCAL_MACHINE \ SOFTWARE \ WOW6432Node \ Android SDK Tools键, Path值,指向Android SDK根目录。

假设你没有安装Visual Studio本身的Android SDK,VS模拟器使用该registry设置(或Android Studio安装registry设置)来查找SDK。 与此,它应该能够findadb.exe和工作。

看看这里:

Xamarinforms的Android应用程序崩溃与VS Android模拟器运行debugging

  1. 启动Hyper-Vpipe理器
  2. select你正在使用的模拟器
  3. 点击右键,点击设置
  4. 点击处理器
  5. 点击兼容性
  6. 设置checkbox“使用不同的处理器版本迁移到物理计算机”

我有一个非常类似的问题。 我发现了两种不同的工作方式,但还没有find一个完整的解决scheme。

尝试部署到它之前启动模拟器

  1. 从开始菜单启动Visual Studio Emulator for Android应用程序的Visual Studio Emulator for Android

  2. 通过绿色箭头启动一个可用的模拟器

    适用于Android的Visual Studio模拟器

  3. 尝试从Visual Studio中再次启动您的应用程序,从下拉菜单中selectVS Emulator N-inch...仿真器

    Visual Studio模拟器列表

对于我来说由于某种原因,应用程序仍然不会在模拟器上“启动”,尽pipe它已经安装。 所以我必须打开应用程序菜单并select我的应用程序。 此外,通常我会尝试打开它几次,但最终会显示我的单一默认标签, Welcome to Xamarin Forms!

Ad-Hoc模式运行应用程序

  1. 在运行应用程序之前,将解决schemeconfiguration(从绿色“运行”button旁边的顶部工具栏)更改为Ad-Hoc


这两种方法的问题虽然是我仍然无法真正debugging应用程序。 我可以运行它,但是我的断点被忽略了,而且一旦我真正开始编写一个真正的应用程序,我认为这会使查找错误变得困难。

我希望一旦找出一个实际的解决scheme来更新这个答案。

我昨天也有同样的问题。 问题出现了(可能),因为我试图在长时间rest后开始开发。 我更新VS和一切,但面临很多问题。

最终你需要重新开始

  1. 确保SDK for emulator指向正确的位置(HKEY_LOCAL_MACHINE \ SOFTWARE \ WOW6432Node \ Android SDK Tools)
  2. 以pipe理员权限运行Visual Studio
  3. 转到Hyper-Vpipe理器并删除所有虚拟交换机 – 让系统在需要时重新创build它们。 它会做得很好
  4. 删除所有现有的模拟器,并在Visual Studio中重新创build它们。 我甚至发现一个评论,没有空格的名称 – 不知道是否需要,但不会伤害。

做这一切帮助了我。 但是我正在重新安装Windows 10 clean。 我觉得很多东西和configuration都改变了,不再兼容。

我以前有这样的问题与Android SDK模拟器,现在我使用Genymotion模拟器,而不是它,它更轻,更快,将自动检测您的VS一旦启动。

你可以从这里下载免费版本: https : //www.genymotion.com/

也可以下载任何设备模拟器。

尝试启用Hyper-V并使用Android的Visual Studio模拟器; 经过大量的尝试和研究,这对我来说很有用

我有同样的问题,但在我的情况下,这不是registry。 在构build版本之后,我将应用程序以释放模式部署到模拟器设备,将应用程序推送到设备,然后有效地“断开连接”。 这就在设备上留下了一个版本的应用程序,似乎阻止了进一步的debugging或部署。

我解决了启动模拟器,去“设置 – >应用程序”,并手动卸载我的应用程序。 然后下一个debugging构build和部署再次工作。

你可能也可以手动启动模拟器,并说“擦拭设备”选项,使其开始新鲜。