无法安装Xamarin.Android.Support.v4

我想安装这个特定的到我的程序,并得到以下错误:

错误无法安装包“Xamarin.Android.Support.Compat 24.2.1”。 您正尝试将此软件包安装到以“MonoAndroid,Version = v6.0”为目标的项目中,但软件包不包含与该框架兼容的任何程序集引用或内容文件。 有关更多信息,请联系软件包作者。

什么是我的项目suppost目标,我该如何做这个改变? 我已经安装了android 7,但我甚至不能针对这个奇怪的原因。 即使我做了一个新项目,我也不能瞄准这个项目。

  • 如何在Windows中zipalign apk文件
  • xamarin中的“布局渲染器失败”错误
  • Visual Studio 2015中“没有可用的设备”
  • 如何在Xamarin CrossPlatform应用程序中使用Web API
  • 快速部署到Android模拟器的应用程序总是失败
  • 该属性没有在基本的xml属性上声明(Android)
  • 应用程序到Android模拟器的快速部署总是失败
  • Xamarin共享项目与可移植类库
  • 这个软件包需要安装MonoAndroid70 。 因此,您需要确保您的TargetFrameworkVersion设置为最低的Android 7.0。 您将需要安装API 24(7.0)并更改版本。

    https://developer.xamarin.com/guides/android/application_fundamentals/understanding_android_api_levels/#framework

    对于那些感兴趣的人,你可以从NuGet下载.nupkg

    https://www.nuget.org/api/v2/package/Xamarin.Android.Support.v4/24.2.1

    然后,您可以提取.nupkg并查看lib文件夹,它将显示库支持的内容。

    我build议下面的步骤

    1-下载以前的版本(

     <package id="Xamarin.Android.Support.v4" version="23.1.1.1" targetFramework="monoandroid60" /> 

    2-删除以下本地文件夹“.. \ AppData \ Local \ Xamarin”

    3-build立droid项目(这将需要一些时间)

    最后,这些xamarin支持包没有更多的问题。

    打起精神来!

    解决scheme:

    • 尝试更新您的Xamarin视觉工作室后,你会安装它,你会得到monoandroid V7
    • 更新你的android sdk Api 24或api 25

    我认为这会帮助你。

    我从Android SDK中删除了所有的API依赖23,即Android 6.0,并从7.0和7.1(AP 24和25)安装。

    清理并重build项目。

    做到这一点,它工作正常。 希望这可以帮助。