针对Cordova插件中的自定义框架定位特定平台

我正在为Android开发一个包含自定义框架的Cordova插件,其中一个只与cordovaandroid> = 4.0.0兼容。

我知道在plugin.xml文件中我们可以针对cordova-android特定版本,但这适用于整个平台的插件。

这是我的plugin.xml的简短版本:

   MyPlugin  =4.0.0" />                

这里,名为“first-framework”的框架仅适用于cordova-android = 4.0.0。

基本上我的目标是只有一个plugin.xml文件声明:

  • 如果cordova-android是<4.0.0:使用“first-framework”
  • 否则,如果cordova-android是> = 4.0.0:使用“second-framework”

我怎么能这样做?

谢谢